Skip to main content
Skip table of contents

.Download iText DITO Java API viText_DITO_2.0

About

The iText DITO Java API is a native Java application. Its prime functionality is to produce PDF documents by merging iText DITO templates with json data.

Download Location

The iText DITO Java API (also referred to as Java SDK) is available for download on JFrog Artifactory: https://repo.itextsupport.com/webapp/#/artifacts/browse/tree/General/dito/com/itextpdf/dito/sdk-java

Deployment and Configuration

Video Tutorial

Step by Step

Installing with Maven

The Java SDK is available as a Maven module. In order to install it, you need the necessary dependency from JFrog Artifactory. First, you need to add the repository to the Maven POM file as follows:

<repositories>
    <repository>
        <id>dito</id>
        <name>DITO Repository</name>
        <url>https://repo.itextsupport.com/dito</url>
    </repository>
</repositories>


Subsequent deployment is easy. Just add the dependency to your POM file like this:

<dependencies>
    <dependency>
        <groupId>com.itextpdf.dito</groupId>
        <artifactId>sdk-java</artifactId>
        <version>${dito.sdk.version}</version>
    </dependency>
</dependencies>


The dito.sdk.version statement is a variable specifying your current version of the framework. The value can for example be 1.3.5


Installing with Gradle

To reference the Java SDK from Gradle, you need the necessary dependency from JFrog Artifactory. First, you need to add the repository to the Gradle build file as follows:

repositories {
    mavenCentral()
    maven {
        url "https://repo.itextsupport.com/dito"
    }
    maven {
        url "https://repo.itextsupport.com/releases"
    }
}

Referencing the dependency is now easy. Just add the corresponding entry to the dependencies section:

dependencies {
    compile group: 'com.itextpdf.dito', name: 'sdk-java', version: ditoSdkVersion
}

The ditoSdkVersion statement is a variable specifying your current version of the framework. The value can for example be 1.3.5.

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.